Charm Bracelet
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 54588 Accepted: 22773

Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight W (1 ≤ W ≤ 400), a 'desirability' factor D (1 ≤ D ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: W and D

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23

Source

OJ-ID:
poj-3624

author:
Caution_X

date of submission:
20191006

tags:
01背包+空间优化

description modelling:
01背包

major steps to solve it:
1.dp[i]:=容量为i时的最大价值
2.dp[j]=max(dp[j],dp[j-w[i]]+v[i]);

warnings:
不使用空间优化会MLE

AC Code:
#include<cstdio>
#include<algorithm>
using namespace std;
int w[3500],v[3500];
int dp[12881];
int main()
{
    int n,k;
    scanf("%d%d",&n,&k);
    for(int i=0;i<n;i++) {
        scanf("%d%d",&w[i],&v[i]);
    }
    for(int i=0;i<n;i++) {
        for(int j=k;j>=w[i];j--) {
            dp[j]=max(dp[j],dp[j-w[i]]+v[i]);
        }
    }
    printf("%d\n",dp[k]);
    return 0;
}
01-18 16:47