求割掉一个点后的连通分量个数最多的m个点

It is the year 95 ACM (After the Crash of Microsoft). After many years of peace, a war has broken out. Your nation, the island of Evergreen Macros And Confusing Shortcuts (EMACS), is defending itself against the railway empire ruled by Visually Impaired Machinists (VIM). In the days leading up to the outbreak of war, your government devoted a great deal of resources toward gathering intelligence on VIM. It discovered the following:
• The empire has a large network of railway stations connected by bidirectional tracks.
• Before the outbreak of the war, each railway station was directly connected to at most 10 other stations. • Information is constantly being exchanged in VIM, but, due to a design flaw, the only way it can be exchanged is to send the messages by train. Before the outbreak of the war, it was possible to send a message by train from any station to any other station. • As a last resort, the empire’s central command can send messages by carrier pigeon, but it tries to avoid this at all costs, as the only pigeons suitable for the job must be imported, at great expense, from the far-away land of Pigeons In Courier Outfits (PICO). • Once a pigeon has delivered a message to a railway station, it must rest, and thus cannot be used again. If a pigeon has delivered a broadcast message to a particular station, the message is passed on, if possible, by train.
Based on this information, the government of EMACS has come up with a plan to disrupt the activities of the evil empire. They will send bomber planes to bomb the railway stations, thus hampering communications in the empire. This will necessitate to acquire many carrier pigeons by the empire, distracting it from its deadly wartime activities. Unfortunately, your government spent so much money on gathering intelligence that it has a very limited amount left to build bombs. As a result, it can bomb only one target. You have been charged with the task of determining the best candidate railway stations in the empire to bomb, based on their “pigeon value”. The “pigeon value” of a station is the minimum number of pigeons that after bombing this station, will be required to broadcast a message from the empire central command to all non-bombed stations. The location of the empire central command is unknown but we know that it is not located at a railway station. This implies, that when the central command needs to send a message to some non-bombed station they have to use at least one pigeon and then the message can be further transmitted by the railway.
Input
The input file contains several test cases. The data for each case begins with a line containing the following two integers: • n the number of railway stations in the empire (3 ≤ n ≤ 10000). The stations will be numbered starting from 0, up to n−1 • m the number of stations to be identified as candidate bombing targets (1 ≤ m ≤ n). Next few lines consists of pairs of integers. Each pair (x,y) indicates the presence of a bidirectional railway line connecting railway stations x and y. This sequence is terminated by a line containing two minus 1 as shown in the sample input. Input is terminated by a case where the value of n = m = 0. This case should not be processed.
Output
For each case of input the output should give m most desirable railway stations to bomb. There should be exactly m lines, each with two integers separated by a single space. The first integer on each line will be the number of a railway station, and the second will be the “pigeon value” of the station. This list should be sorted, first by “pigeon value”, in descending order, and within the same “pigeon value” by railway station numbers, in ascending order. Print a blank line after the output for each set of input.
Sample Input
8 4

0 4

1 2

2 3

2 4

3 5

3 6

3 7

6 7

-1 -1

0 0
Sample Output
2 3

3 3

4 2

0 1

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
using namespace std;
const int MAXN=10009;
const int MAXM=1000009;
struct Edge
{
    int to,next;
}edge[MAXM];
int head[MAXN],tot;
int Low[MAXN],DFN[MAXN];
int Index;
bool cut[MAXN];
struct node
{
    int id,num;
}add_block[MAXN];
void addedge(int u,int v)
{
    edge[tot].to=v;edge[tot].next = head[u];
    head[u]=tot++;
    //cout<<head[u]<<endl;
}
void Tarjan(int u,int pre)
{
    int v;
    Low[u] = DFN[u]=++Index;
    int son=0;
    for(int i = head[u];i != -1;i = edge[i].next)
    {
        v = edge[i].to;
        if(v == pre)continue;
        if(!DFN[v])
        {
            son++;
            Tarjan(v,u);
            if(Low[u]> Low[v])Low[u] = Low[v];
            if(u != pre && Low[v] >= DFN[u])
                add_block[u].num++;
        }
        else if( Low[u] > DFN[v])
            Low[u] = DFN[v];
    }
    if(u==pre) add_block[u].num=son-1;
}
int cmp(node a,node b)
{
    if(a.num!=b.num)
        return a.num>b.num;
    else
        return a.id<b.id;
}
int main()
{
    int n,u,v,m;
    while(~scanf("%d %d",&n,&m)&&n&&m)
    {
        tot=0;Index=0;
        memset(head,-1,sizeof(head));
        memset(cut,0,sizeof(cut));
        memset(DFN,0,sizeof(DFN));
        for(int i=0;i<n;i++)
        {
            add_block[i].id=i;
            add_block[i].num=0;
        }
        while(scanf("%d %d",&u,&v)&&u!=-1&&v!=-1)
        {
            addedge(u,v);
            addedge(v,u);
        }
        for(int i=0;i<n;i++)
            if(!DFN[i])
                Tarjan(i,i);
        sort(add_block,add_block+n,cmp);
        for(int i=0;i<m;i++)
            printf("%d %d\n",add_block[i].id,add_block[i].num+1);
        printf("\n");
    }

    return 0;
}

 

10-03 15:51