K-th Number
Time Limit: 20000MS Memory Limit: 65536K
Total Submissions: 52651 Accepted: 18091
Case Time Limit: 2000MS

Description

You are working for Macrohard company in data structures department. After failing your previous task about key insertion you were asked to write a new data structure that would be able to return quickly k-th order statistics in the array segment.
That is, given an array a[1...n] of different integer numbers, your
program must answer a series of questions Q(i, j, k) in the form: "What
would be the k-th number in a[i...j] segment, if this segment was
sorted?"

For example, consider the array a = (1, 5, 2, 6, 3, 7, 4). Let the
question be Q(2, 5, 3). The segment a[2...5] is (5, 2, 6, 3). If we sort
this segment, we get (2, 3, 5, 6), the third number is 5, and therefore
the answer to the question is 5.

Input

The
first line of the input file contains n --- the size of the array, and m
--- the number of questions to answer (1 <= n <= 100 000, 1 <=
m <= 5 000).

The second line contains n different integer numbers not exceeding 10 by their absolute values --- the array for which the answers should be given.

The following m lines contain question descriptions, each
description consists of three numbers: i, j, and k (1 <= i <= j
<= n, 1 <= k <= j - i + 1) and represents the question Q(i, j,
k).

Output

For each question output the answer to it --- the k-th number in sorted a[i...j] segment.

Sample Input

7 3
1 5 2 6 3 7 4
2 5 3
4 4 1
1 7 3

Sample Output

5
6
3

Hint

This problem has huge input,so please use c-style input(scanf,printf),or you may got time limit exceed.
【分析】第一道划分树,懂了一丝,继续努力。。。

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <time.h>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#define met(a,b) memset(a,b,sizeof a)
#define pb push_back
#define lson(x) ((x<<1))
#define rson(x) ((x<<1)+1)
using namespace std;
typedef long long ll;
const int N=1e5+50;
const int M=N*N+10;
struct P_Tree {
    int n;
    int tree[20][N];
    int sorted[N];
    int toleft[20][N];
    void init(int len) {
        n=len;
        for(int i=0; i<20; i++)tree[i][0]=toleft[i][0]=0;
        for(int i=1; i<=n; i++) {
            scanf("%d",&sorted[i]);
            tree[0][i]=sorted[i];
        }
        sort(sorted+1,sorted+n+1);
        build(1,n,0);
    }
    void build(int l,int r,int dep) {
        if(l==r)return;
        int mid=(l+r)>>1;
        int same=mid-l+1;
        for(int i=l; i<=r; i++)
            if(tree[dep][i]<sorted[mid])
                same--;
        int lpos=l;
        int rpos=mid+1;
        for(int i=l; i<=r; i++) {
            if(tree[dep][i]<sorted[mid]) { //去左边
                tree[dep+1][lpos++]=tree[dep][i];             } else if(tree[dep][i]==sorted[mid]&&same>0) { //去左边
                tree[dep+1][lpos++]=tree[dep][i];
                same--;
            } else //去右边
                tree[dep+1][rpos++]=tree[dep][i];
            toleft[dep][i]=toleft[dep][l-1]+lpos-l;//从1到i放左边的个数
        }
        build(l,mid,dep+1);//递归建树
        build(mid+1,r,dep+1);
    }
    int query(int L,int R,int l,int r,int dep,int k) {
        if(l==r)return tree[dep][l];
        int mid=(L+R)>>1;
        int cnt=toleft[dep][r]-toleft[dep][l-1];
        if(cnt>=k) {
            //L+查询区间前去左边的数的个数
            int newl=L+toleft[dep][l-1]-toleft[dep][L-1];
            //左端点+查询区间会分入左边的数的个数
            int newr=newl+cnt-1;
            return query(L,mid,newl,newr,dep+1,k);//注意
        } else {
            //r+区间后分入左边的数的个数
            int newr=r+toleft[dep][R]-toleft[dep][r];
            //右端点减去区间分入右边的数的个数
            int newl=newr-(r-l-cnt);
            return query(mid+1,R,newl,newr,dep+1,k-cnt);//注意
        }
    }
}tre;
int main() {
    int n,m;
    int u,v,w;
    while(~scanf("%d%d",&n,&m)) {
        tre.init(n);
        while(m--) {
            scanf("%d%d%d",&u,&v,&w);
            printf("%d\n",tre.query(1,n,u,v,0,w));
        }
    }
    return 0;
}
05-29 00:25